San Carlos, Sonora, Mexico Forums Home 

San Carlos Mexico Forum
Welcome to our forum. In order to post in our forums you must be registered. Please take a minute to register to enjoy the full benefits of the forum. Registration is FREE and your information is kept private. When registering, please make sure your email address is entered correctly-if incorrect, you will not receive your validation message. Please do not use your email address as your user name for your own privacy and security. Gmail account users should check spam or trash folders for our validation message after initial registration. We also suggest you add host@sancarlosmexico.com to your white list.

This message board requires you to register in order to post new topics, reply to topics started by other users, start polls, or vote on polls. As a registered user, you can edit your own posts, upload photos and view our photo gallery, and send private messages to other members of the board. Registered users can keep track of the topics they are interested in, and receive e-mail notifications when someone posts to one of those topics. Registered users can choose a theme and setup a profile, to include hometown, email & web address and avatar if desired.
We do ask that you post in the appropriate forum-look over the subjects and topics of all forums including the mercado section before making your first post. Posts in the wrong forum or not related to San Carlos may be moved or deleted without notice.
Please take a moment and register to enjoy all the benefits of the forum.
Bienvenidos!

 Moderated by: bartmanaz
New Topic Reply Printer Friendly
Avet reel cleaning?  Rate Topic 
AuthorPost
 Posted: Mon Feb 13th, 2017 01:22 pm
  PM Quote Reply
1st Post
siskiyoumike
Member
 

Joined: Tue Oct 3rd, 2006
Location: Weed, California USA
Posts: 27
Status: 
Offline
Mana: 
Anyone in our area that can clean/problem solve an Avet JX Raptor reel? I have an inconsistent lever drag issue that I believe might be solved by a simple cleaning (reel was serviced by Avet in September 2016). The reel works perfectly most of the time, but it has briefly failed to engage the drag a couple of times over the last week. I would be foolish enough to try to take it apart myself but I have neither the tools or the eyesight to attempt. Thanks for any leads offered.

Back To Top PM Quote Reply  

 Posted: Mon Feb 13th, 2017 02:06 pm
  PM Quote Reply
2nd Post
Bullshipper
Member
 

Joined: Thu Aug 23rd, 2012
Location:  
Posts: 1196
Status: 
Offline
Mana: 
i you go to reelforums there are tutorials with pictures to guide the person you choose to help you

Back To Top PM Quote Reply

 Posted: Tue Feb 14th, 2017 12:07 am
  PM Quote Reply
3rd Post
siskiyoumike
Member
 

Joined: Tue Oct 3rd, 2006
Location: Weed, California USA
Posts: 27
Status: 
Offline
Mana: 
Thanks Bullshipper. I did go to Home Depot and get the correct hex tools needed to open the reel, and I just looked at the service video. A bit beyond my ability, but I doubt that fact will stay my hand for very long.

Back To Top PM Quote Reply  

 Posted: Tue Feb 14th, 2017 03:10 pm
  PM Quote Reply
4th Post
Bullshipper
Member
 

Joined: Thu Aug 23rd, 2012
Location:  
Posts: 1196
Status: 
Offline
Mana: 
Mike
You may know the following about Avets. If not this may benifit you.
Avet drag washers are not greased. If they have not been used much, I would advise you to tie the line on your car bumper and run out 150 yds of line under good drag pressure to break them in and make them more consistent.This will cut down on the swelling they may get when washed.
If that does not work, then I would grease them with some Cal's Drag Grease to make them waterproof and more consistent. I have some of that grease.I grease mine now when new after trying them both ways.

Back To Top PM Quote Reply

 Posted: Tue Feb 14th, 2017 03:11 pm
  PM Quote Reply
5th Post
Bullshipper
Member
 

Joined: Thu Aug 23rd, 2012
Location:  
Posts: 1196
Status: 
Offline
Mana: 
You have to run the line out 3-5 time untill you feel that the drag is smooth under pull.

Back To Top PM Quote Reply  

 Posted: Tue Feb 14th, 2017 10:12 pm
  PM Quote Reply
6th Post
siskiyoumike
Member
 

Joined: Tue Oct 3rd, 2006
Location: Weed, California USA
Posts: 27
Status: 
Offline
Mana: 
Bullshipper, thanks for the advice on how to get the drag smoothed out quickly. It certainly was inconsistent until after the first twenty or so yellowtail, but it gradually seemed to work really well. My problem this year is something new, at least to me. I store my Avet JX Raptor with the drag in free spool. My strike is often set to about 14 pounds. Anyway, when I was getting ready in the morning to head out, I slide the lever drag to strike position and noticed that I still had no drag at all. So, although the lever was in strike position, which should have about 14 pounds of drag, the spool moved freely to let out line (the crank handle spun forward as the line played out). If I held the handle, my arm became the resistance. I fiddled around with the reel for a few minutes, loosening the knurled drag and moving the drag lever back and forth, and even changing the speed. After a couple of minutes everything worked correctly, and I went fishing. It worked fine all day, but the issue has me worried that it could occur again at the wrong time. I will send the reel off to Avet at the end of the season, as I do each year, but I need the reel to work until then. As I do not really know much about how everything functions inside the reel, I have no idea whether the problem is just a bit of salt, a bad bearing, or a spring issue?
Michael

Back To Top PM Quote Reply

 Posted: Wed Feb 15th, 2017 12:41 am
  PM Quote Reply
7th Post
Bullshipper
Member
 

Joined: Thu Aug 23rd, 2012
Location:  
Posts: 1196
Status: 
Offline
Mana: 
Yes, hard to guess. Might want to just unscew the drag adjustment knob and spray a little wd40 into that cavity before putting the knob in to make sure the grease has not dried and hardened.

I own a 2 speed Jx Raptor too but hardly ever use it. If your fails let me know.

Back To Top PM Quote Reply  

 Posted: Wed Feb 15th, 2017 06:27 pm
  PM Quote Reply
8th Post
siskiyoumike
Member
 

Joined: Tue Oct 3rd, 2006
Location: Weed, California USA
Posts: 27
Status: 
Offline
Mana: 
Bullshipper,I watched the Avet service video a few more times and decided to open the reel up for a look. All bearings seemed to work well, but the area around the dog had a bit of crud. I cleaned the dog area as well as I could and put the reel back together. It appears to work fine now, but I will not know until after a few days of fishing. Thanks for the responses, and I will pm if I need to buy another reel.Michael

Back To Top PM Quote Reply

Current time is 10:42 pm  
San Carlos, Sonora, Mexico Forums > Topical Forums > San Carlos Fishing Forum > Avet reel cleaning? Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems